NYCPHP Meetup

OT:ftp EPSV error..

Ian Forsyth ian at plusfour.org
Wed Feb 26 19:29:43 EST 2003


Hello from the wild west.

Wondering if anyone has run into this error..  here is the debug output 
from my ftp client, command line Mac OS X ftp client (aka freebsd 4.4 i 
think)..

215 UNIX Type: L8
Remote system type is UNIX.
Using binary mode to transfer files.
---> FEAT
500 'FEAT': command not understood.
features[0] = 0
features[1] = -1
features[2] = -1
features[3] = -1
features[4] = -1
features[5] = -1
---> PWD
257 "/u/ftpsecure" is current directory.
got remotepwd as `/u/ftpsecure'
ftp> ls
---> EPSV
500 'EPSV': command not understood.
disabling epsv4 for this connection
---> PASV
227 Entering Passive Mode (192,168,0,75,203,86)

connection times out..

I am behind a router that is doing NAT, no real firewall.. the remote 
ftp server is behind NAT/Firewall.. the remote server's internal ip 
address is 192.168.0.75. There is one ip address assigned to the remote 
location, depending on the port request made to the remote router.. the 
appropriate internal ip is requested..

Via mac os x command line ftp I cannot see the results of the ls 
command behind the NAT router on a 192.168.x.x ip, but on an outside on 
a world reachable ip i can view the results of ls.

On a windows machine using ws ftp LE and behind the NAT having a 
192.168.X.X ip a LS command times out as well..  Though when the 
windows machine is on the external network, with a 207.33.X.X ip the ws 
ftp client functions normaly..

I can connect to hundreds of machines behind the NAT router, it is just 
this one server i cannot connect to.... and it happens to be a server 
that needs to be reachable from this office (of course) on a daily 
basis for uploading source, and beta builds..

The router that is doing nat locally is a netopia cayman, firewall is 
set to 'Clear Sailing' on the router, meaning i assume not blocking 
anything..

What can be done? on my side or on the server side? In news groups this 
seems to be a BSD ftp client issue.. and a ws ftp client issue, I have 
tried several clients, none of them can connect. I have no idea on how 
to solve this.. we will be loosing the 207.33.X.X network in a few 
weeks (too expensive for T1 access).. how can I trace this? Is there 
anyway possible that it is the remote ftp server issue?

this is the debug from the 'not behind the nat ip'

---> SYST
215 UNIX Type: L8
Remote system type is UNIX.
Using binary mode to transfer files.
---> FEAT
500 'FEAT': command not understood.
features[0] = 0
features[1] = -1
features[2] = -1
features[3] = -1
features[4] = -1
features[5] = -1
---> PWD
257 "/u/ftpsecure" is current directory.
got remotepwd as `/u/ftpsecure'
ftp> ls
---> EPSV
500 'EPSV': command not understood.
disabling epsv4 for this connection
---> PASV
227 Entering Passive Mode (192,168,0,75,203,102)
---> PORT 207,33,X,X,194,220
200 PORT command successful.
---> LIST
150 Opening ASCII mode data connection for /usr/bin/ls.
total 18

Any help would be great. How is everybody doing in nyc? I am san 
francisco these days.. Sorry for the off topic post, again any help 
would be super.. thanks

Ian Forsyth




More information about the talk mailing list