NYCPHP Meetup

[joomla] Joomla 1.7, front page not loading server 500 error but admin works.

David Roth davidalanroth at gmail.com
Mon Dec 26 18:29:50 EST 2011


Thanks for the reply Lucas. Error were enabled for this Joomla
installation so I turned them on and found this in the log:
[26-Dec-2011 18:24:44] PHP Fatal error:  Call to undefined function
mb_internal_encoding() in
/home/www/html/youplusdemoj17/components/com_k2/helpers/route.php on
line 52

I'm not familiar with the internals to Joomla, but here is the PHP
code leading up to line 52. Line 52, "
mb_internal_encoding("UTF-8");" is the last line in this code
fragment.

        function getUserRoute($userID) {
                $needles = array (
                        'user'=>(int)$userID
                );
                $user = &JFactory::getUser($userID);
                if(K2_JVERSION == '16' &&
JFactory::getConfig()->get('unicodeslugs') == 1) {
                        $alias = JApplication::stringURLSafe($user->name);
                }
                else if(JPluginHelper::isEnabled('system',
'unicodeslug') || JPluginHelper::isEnabled('system',
'jw_unicodeSlugsExtended')){
                        $alias = JFilterOutput::stringURLSafe($user->name);
                } else {
                        mb_internal_encoding("UTF-8");

David Roth
On Mon, Dec 26, 2011 at 6:12 PM, Lucas Webempresa <lucas at webempresa.com> wrote:
> Hi David,
>
> See in the public_html/error_log to see why do you have the error 500.
>
> Regards
> Lucas
>
>
> 2011/12/26 David Roth <davidalanroth at gmail.com>
>>
>> I've gotten a template from youjoomla.com and while it does install,
>> their demo version supplied with .sql files doesn't. I never had this
>> happen with Joomla before. However, I can login as admin and access
>> everything in the demo version, but the main (front) page won't load
>> and display. It comes up with a server 500 error which doesn't make
>> sense to me because I have another installation of Joomla 1.7 running
>> fine in another directory.
>>
>> I've not run across this problem before so I thought I would ask here
>> to see if anyone has some suggestions what might be the cause of this.
>> Again, as admin I can see all the demo data in there and access
>> everything there, the site pages just don't work. Thanks!
>>
>> David Roth
>> _______________________________________________
>> New York PHP SIG: Joomla! Mailing List
>> http://lists.nyphp.org/mailman/listinfo/joomla
>>
>> NYPHPCon 2006 Presentations Online
>> http://www.nyphpcon.com
>>
>> Show Your Participation in New York PHP
>> http://www.nyphp.org/show_participation.php
>
>
>
>
> --
> Saludos
> Lucas
>
>
> _______________________________________________
> New York PHP SIG: Joomla! Mailing List
> http://lists.nyphp.org/mailman/listinfo/joomla
>
> NYPHPCon 2006 Presentations Online
> http://www.nyphpcon.com
>
> Show Your Participation in New York PHP
> http://www.nyphp.org/show_participation.php



More information about the Joomla mailing list