NYCPHP Meetup

[nycphp-talk] uploads

Brian brian at preston-campbell.com
Wed Feb 19 11:59:41 EST 2003


I left them as $_FILES but meant to say I tried $HTTP_POST_FILES to see if 
that had any effect.

The odd thing is that I am not getting any errors when I upload a file.  In 
the upload script I am checking that a file was uploaded, the type of file 
uploaded, the size, etc and if a file in the destination directory already 
has the same name as the file being uploaded.  The only time I get any type 
of error is when I am trying to upload a file with the same name as one in 
the directory.

According to PHP, the file upload is taking place.  The database info reflects 
that as well, as nothing is written to it until the uploaded file is 
verified.  Odd.

I have contacted the sysadmin and am awaiting a response.  I am hoping to 
resolve the issue myself but this may not be possible.  Also, I have not been 
able to reproduce the situation on my local machine (LAMP with PHP 4.3.0, 
same as the host server).

Brian

On Wednesday 19 February 2003 11:44 am, Analysis & Solutions wrote:
> Hi Brian:
>
> On Tue, Feb 18, 2003 at 12:02:11PM -0500, Brian wrote:
> > Anyone know what would have changed in 4.3.0 that would hinder my
> > attempts to
> > upload files with scripts that worked in previous versions?
> >
> > I had already replaced $_FILES with $HTTP_POST_FILES
>
> That should be the other way around.  $_FILES is the thing to use.
>
> Anyway, if you're using the Apache Module version, the required
> permissions on directories has changed.  They need to be world readable
> and executable (chmod 705).  Perhaps this is is your difficulty?
>
> Enjoy,
>
> --Dan





More information about the talk mailing list